poj1442&poj2892

poj3481

Hydra posted @ 2015年3月09日 21:13 in poj with tags Treap poj , 968 阅读

Treap.

Double Queue
Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0 The system needs to stop serving
K P Add client K to the waiting list with priority P
2 Serve the client with the highest priority and drop him or her from the waiting list
3 Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

Source

/*
Problem: 3481
User: Childe
Memory: 3912K
Time: 375MS
Language: C++
Result: Accepted
*/
#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;

struct Treap{
	Treap *l,*r;
	int key,fix,size,num;
	Treap(int num_,int key_):fix(rand()),key(key_),l(NULL),r(NULL),size(1),num(num_){
	}
	inline void update(){
		size=1+(l?l->size:0)+(r?r->size:0);
	}
};

Treap *root;

typedef pair<Treap*,Treap*>Droot;

inline int size(Treap *x){
	return x?x->size:0;
}

Droot Split(Treap *x,int k){
	if(!x)return Droot(NULL,NULL);
	Droot y;
	if(size(x->l)>=k){
		y=Split(x->l,k);
		x->l=y.second;
		x->update();
		y.second=x;
	}
	else{
		y=Split(x->r,k-size(x->l)-1);
		x->r=y.first;
		x->update();
		y.first=x;
	}
	return y;
}

Treap *Merge(Treap *x,Treap *y){
	if(!x)return y;
	if(!y)return x;
	if(x->fix<y->fix){
		x->r=Merge(x->r,y);
		x->update();
		return x;
	}
	else{
		y->l=Merge(x,y->l);
		y->update();
		return y;
	}
}

int Getkth(Treap *x,int v){
	if(!x)return 0;
	return v<x->key?Getkth(x->l,v):Getkth(x->r,v)+size(x->l)+1;
}

void Insert(int v,int p){
	int k=Getkth(root,p);
	Droot x=Split(root,k);
	Treap *n=new Treap(v,p);
	root=Merge(Merge(x.first,n),x.second);
}

void Delete(int k){
	Droot x=Split(root,k-1);
	Droot y=Split(x.second,1);
	printf("%d\n",y.first->num);
	root=Merge(x.first,y.second);
}

void Getmax(Treap *x){
	if(!x){printf("0\n");return;}
	Delete(x->size);
}

void Getmin(Treap *x){
	if(!x){printf("0\n");return;}
	Delete(1);
}

int main(){
	int opt,k,p;
	scanf("%d",&opt);
	while(opt!=0){
		if(opt==1){
			scanf("%d%d",&k,&p);
			Insert(k,p);
		}
		if(opt==2)Getmax(root);
		if(opt==3)Getmin(root);
		scanf("%d",&opt);
	}
	return 0;
}

 


登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter